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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
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interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It demonstrates how to model an RF amplifier using Ansys Icepak as well as many fea-
tures and functions essential to any Ansys Icepak project.

In this tutorial you will learn how to:

l Create a new project
l Create a model using openings, fans, sources, blocks, heat sinks, and walls
l Use non-conformal meshing
l Set up a simulation with various physical conditions and parameters, including turbulence
and natural convection

l Calculate a solution
l Post-process your results by using power and temperature limits, object faces, plane cuts,
isosurfaces and variation plots

This chapter contains the following topic:

l "Sample Project - The RF Amplifier" below

Sample Project - The RF Amplifier
RF amplifiers are typically sealed enclosures that are placed within larger systems. They present
a challenge from the thermal management perspective because no direct exchange of air exists
between the interior of the amplifier and the ambient. The common method of cooling such sub-
systems is to mount a large heat sink on the amplifier housing that cools all the devices within the
enclosure. A simplified version of an RF amplifier will serve as the model for this tutorial. There
will be free convection inside the amplifier and forced convection in the external domain.

Figure 1-1: RF Amplifier

Getting Started with Icepak®: RF Amplifier
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Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

3. ClickOK.

Introduction 1-2
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2 - Create a Project and Build the Model
After launching the Ansys Electronics Desktop, create a project, insert an Icepak design, and
build the model.

Set Beta Option

Note: To use Slack settings, enable the Icepak Virtual Mesh Regions beta options in
the General Options.

1. From the Toolsmenu, selectOptions > General Options.
2. In theOptions dialog box, expandGeneral > Desktop Configuration.
3. Click Beta Options.
4. Enable Icepak Virtual Mesh Regions and clickOK.
5. ClickOK to close theOptions dialog box.

Create a Project
1. On the Desktop ribbon, click New.
2. From the Projectmenu, select Insert Icepak Design.
3. In the Project Manager, right-click on the project name and select Rename.
4. Rename the project "RF_Amplifier."
5. From the Filemenu, select Save.
6. Save the project in your working directory.

Build the Model
Resize the Cabinet

1. In the History tree, expandModel > Solids > air > Region and select CreateRegion.
2. In the Properties window, define the following parameters:

l +X Padding Type: Absolute Position
l +X Padding Data: 0.1 meter
l -X Padding Type: Absolute Position
l -X Padding Data: 0 meter
l +Y Padding Type: Absolute Position
l +Y Padding Data: 0.6 meter

Getting Started with Icepak®: RF Amplifier
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l -Y Padding Type: Absolute Position
l -Y Padding Data: 0 meter
l +Z Padding Type: Absolute Position
l +Z Padding Data:0.25 meter
l -Z Padding Type: Absolute Position
l -Z Padding Data: -0.05 meter

Create the Opening
Create opening sheet geometry for the opening. The geometry serves as the assignment for the
opening thermal boundary condition and, later this in this guide, a flow monitor point.

1. From the Drawmenu, select Rectangle.
2. Press F4 to enter dialog entry mode.

Note: You can toggle between drawing methods by pressing F3 (point mode) or
F4 (dialog entry mode).

3. In the CreateRectangle dialog box Command tab, define the following size parameters
and units:

l Position: 0 ,0.6 ,-0.05 meter
l Axis: Y
l Length: 0.1 meter
l Width: 0.3 meter

4. On the Attribute tab, enter cabinet_default_side_maxy for the Name.
5. ClickOK.
6. In the History tree, expandModel > Sheets > Unassigned.
7. Right-click cabinet_default_side_maxyand select Assign Thermal > Opening > Free.
8. In theOpening Thermal Model dialog box, enter cabinet_default_side_maxy as the

Name.

Create a Project and Build the Model 2-2
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9. Click OK to accept the default thermal and flow specifications.

Create the Housing Plates
1. From the Drawmenu, select Rectangle.
2. In the CreateRectangle dialog box Command tab, define the following size parameters

and units:
l Position: 0 ,0.45 ,0 meter
l Axis: Y
l Length: 0.2 meter
l Width: 0.06 meter

3. On the Attribute tab, enter Housing_maxy for the Name.
4. ClickOK.
5. Repeat steps 2 through 5 to create the remaining three housing plates based on the spe-

cifications in the following table.

Note: The order of the Length andWidth rows changes based on the Axis
selection. Ensure that you enter the width and length values into the correct cells
when editing the size properties.

Name Position Axis Width Length

Housing_maxz 0 ,0.15 ,0.2 meter Z 0.06 meter 0.3 meter
Housing_miny 0 ,0.15 ,0 meter Y 0.2 meter 0.06 meter
Housing_minz 0 ,0.15 ,0 meter Z 0.06 meter 0.3 meter
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6. In the History tree, right-click Housing_maxy and select Assign Thermal > Plate > Con-
ducting.

7. In the Conducting Plate Thermal Model dialog box, define the following parameters:
l Name: Housing_maxy
l Thermal Specification: Thickness
l Thickness: 0.001 meter
l Solid Material: Polystyrene-rigid-R12
l Shell Conduction: Enabled

8. ClickOK.
9. Repeat steps 7 and 8 for Housing_maxz, Housing_miny, and Housing_minz.

Create the Wall
Create a wall on the Xmin face of the amplifier housing to cover the Xmin side of the enclosure.

1. From the Drawmenu, select Rectangle.
2. In the CreateRectangle dialog box Command tab, define the following size parameters

and units:
l Position: 0 ,0.15 ,0 meter
l Axis: X
l Width: 0.3 meter
l Length: 0.2 meter

3. On the Attribute tab, enter Xmin for the Name.
4. ClickOK.
5. In the History tree, expandModel > Sheets > Unassigned.
6. Right-click Xmin and select Assign Thermal > Wall > Stationary.

Create a Project and Build the Model 2-4
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7. In the Stationary Wall Thermal Model dialog box, define the following parameters:
l Name: Xmin
l Wall Thickness: 0.001 meter
l Solid Material: Polystyrene-rigid-R12
l External Condition: Heat Transfer Coefficient
l Heat Transfer Coefficient: 5 w_per_m2kel

8. ClickOK.

Create the PCB
Model the PCB using box geometry and a user-defined material with custom properties.

Create the PCB Material
1. From the Toolsmenu, select Edit Libraries > Materials.
2. In the Edit Libraries dialog box, Click Add Material.
3. In the View/Edit Materials dialog box, define the following properties:

l Name: pcb_1_substrate
l Thermal Conductivity Type: Anisotropic
l T(1,1) Value: 0.361276W/m-C
l T(2,2) Value: 9.30516W/m-C
l T(3,3) Value: 9.30516W/m-C
l Mass Density Value: 1427.669375 kg/m^3
l Specific Heat Value: 1277.8579921875 J/kg-C

4. ClickOK to close the View/Edit Materials dialog box.
5. ClickOK to close the Edit Libraries dialog box.

Create a Project and Build the Model 2-5
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Create the PCB Geometry and Assign the Material
1. From the Drawmenu, select Box.
2. In the CreateBox dialog box, define the following size parameters and units:

l Position: 0.0584 ,0.15 ,0 meter
l XSize: 0.0016 meter
l YSize: 0.3 meter
l ZSize: 0.2 meter

3. On the Attribute tab, define the following parameters:
l Name: pcb_1_substrate
l Material: pcb_1_substrate

4. ClickOK.

Create the Devices
There are twelve devices on the bottom side of the PCB. Model the devices as rectangle geo-
metry and assign source thermal boundary conditions to define thermal properties.

Create a Device
1. From the Drawmenu, select Rectangle.
2. In the CreateRectangle dialog box Command tab, define the following size parameters

and units:
l Position: 0.0584 ,0.194 ,0.035 meter
l Axis: X
l Width: 0.016 meter
l Length: 0.02 meter

Create a Project and Build the Model 2-6
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3. On the Attribute tab, enter device for the Name.
4. ClickOK.

Create Duplicates of the Device
Using the first device as a template, create two duplicates in the Z direction. Then create three
duplicates of those devices in the Y direction to create all twelve.

1. In the History tree, expandModel > Sheets > Unassigned.
2. In the History tree, right-click device and select Edit > Duplicate > Along Line.
3. In the DuplicateAlongLine dialog box, enter 3 for Total Number.
4. Enter 0 ,0 ,0.055 for the Vector to copy the device in the Z direction.
5. Change the Unit tometer.
6. Click OK.
7. In the History tree, expandModel > Sheets > Unassigned.
8. In the History tree, use the Ctrl key to select device, device_1, and device_2.
9. Right-click and select Edit > Duplicate > Along Line.
10. In the DuplicateAlongLine dialog box, enter 4 for Total Number.
11. Enter 0 ,0.064 ,0 for the Vector to copy the devices in the Y direction.
12. Change the Unit tometer.
13. Click OK.

Assign the Source Boundary Condition
Each device has a total power of 7 W. When assigning a boundary condition to multiple objects,
the thermal properties are applied to all twelve devices.

1. In the History tree underModel > Sheets, right-click Unassigned and select Select All.
2. Right-click select Assign Thermal > Source.

Create a Project and Build the Model 2-7
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3. In the Source Thermal Model dialog box, define the following parameters:
l Name: Devices
l Thermal Condition: Total Power
l Total Power: 7 W

4. Click OK.

Create the Heatsink
Create an extruded fin heat sink with the flow in the Y direction to remove heat from the PCB.
Use theMove feature to position the heatsink.

1. In the Project Manager, right-click 3D Components and select Create > Heatsink.
2. On the Heatsink Component Geometry tab, define the following parameters:

l Plane: YZ
l Overall height: 0.04 meter
l Base Length: 0.3 meter
l Base Width: 0.2 meter
l Base Height: 0.004 meter
l Fin Type: Extruded
l Flow Direction: Y
l Fin Count: 9
l Fin Thickness: 0.002 meter
l Y Offset: 0 meter
l Z Offset: 0 meter

3. On the Properties tab, review the Solid Material and Surface Material selections for the
fins and base.

4. ClickOK.
5. In the History tree under Heatsink1, right-click Heatsink1_1 and select Edit > Arrange

> Move.
6. In theMove dialog box, enter 0.06 ,0.3 ,0.1 for theMove Vector.
7. Change the Unit tometer.
8. Click OK.

Create the Fan
For this model, add an existing fan from the Component Libraries.

Note: Ensure the Component Libraries window is displayed by selecting Com-
ponent Libraries from the Viewmenu.
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1. In the Component Libraries window, expand Icepak Components > Fan > Delta.
2. Double-click Delta_FFB0812_24EHE to add the fan component to the model.
3. In the Project Manager under 3D Components, right click delta_FFB0812_24EHE and

select Edit Definition.
4. In the Fan Component dialog boxGeometry tab, change the Cross-section to ZX.
5. On the Properties tab, review the thermal and flow properties.
6. ClickOK.
7. In the History tree, expand delta_FFB0812_24EHE.
8. Right-click delta_FFB0812_24EHE1 and select Edit > Arrange > Move.
9. In theMove dialog box, enter 0.05 ,0 ,0.1 for theMove Vector Value.
10. Change the Unit tometer.
11. Click OK. Review the final geometry.

View the Design List
Display the Design List to review the model geometry and thermal boundary condition assign-
ments.

1. From the Icepakmenu, select List.
2. On theModel tab, review the model geometry.

Create a Project and Build the Model 2-9
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3. Click the Thermal tab and review the boundary condition assignments.
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3 - Generate and Display Coarse Mesh
After building the model, generate and display the mesh.

Generate a Coarse Mesh
1. In the Project Manager, right-clickMesh and select Edit Global Region.
2. On the Advanced tab, disable the User specified check box.
3. On theGeneral tab under Auto Mesh Setting, ensure the slider bar is in the middle

between Coarse/Small and Fine/Large position.

4. ClickOK.
5. In the Project Manager, right-clickMesh and selectGenerate Mesh.

Display the Coarse Mesh
TheMesh Visualization dialog box automatically appears after the meshing process com-
pletes.

1. In theMesh Visualization dialog box underMesh display on, enable Show and select
Geometry/Boundary selection.

2. In the History tree, right-clickModel and select Select All.
3. On theModel ribbon, select Front from theOrient drop-down list.

Getting Started with Icepak®: RF Amplifier
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4. Click Close.
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4 - Assign Mesh Regions
To generate a finer mesh in the fan and enclosure, create two mesh regions. The first mesh
region consists of the RF amplifier; the second consists only of the fan.

Create the RF Amplifier Mesh Region
The RF amplifier consists of the wall, enclosure plates, and heatsink. First create a non-model
box to encompass all of the components.

Create a Non-Model Box
Non-model geometry do not have thermal or material assignments and can be used to assign
mesh regions to custom shapes.

1. From the Drawmenu, select Box.
2. In the CreateBox dialog box, define the following size parameters and units:

l Position: 0 ,0.13 ,-0.01 meter
l XSize: 0.1 meter
l YSize: 0.37 meter
l ZSize: 0.22 meter

3. On the Attribute tab, define the following parameters:
l Name: amplifier_meshregion
l Model: Disabled

4. Click OK.

Assign a Mesh Region to the Non-Model Box
1. In the History tree, expandModel > Solids > Non-Model.
2. Right-click amplifier_meshregion and select Assign Mesh Region.
3. In the SubRegion dialog box, clickOK to close the dialog box without adding padding.
4. In theMesh Region dialog box, enter Amplifier for the Name.
5. Under Auto Mesh Setting, move the slider bar to the Fine/Large position.
6. ClickOK.

Assign a Mesh Region to the Fan Component
1. In the Project Manager under 3D Components, select delta_FFB0812_24EHE1.
2. In the 3D Modeler window, right-click and select Assign Mesh Region.
3. On the SubRegion dialog box, select Pad individual directions for Padding Data.
4. For each Direction, select Absolute Offset from the Padding type drop-down and enter

the following values.
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l +X: 0.01 mm
l -X: 0.01 mm
l +Y: 0.05 mm
l -Y: 0 mm
l +Z: 0.01 mm
l -Z: 0.01 mm

5. In theMesh Region dialog box, enter Fan for the Name.
6. Under Auto Mesh Setting, move the slider bar to the Fine/Large position.
7. ClickOK.
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5 - Generate and Display Refined Mesh
After creating the mesh regions, generate and display the mesh.

Generate and Display Refined Mesh
1. In the Project Manager, right-clickMesh and selectGenerate Mesh. TheMesh Visu-

alization dialog box automatically appears after the meshing process completes.
2. In theMesh Visualization dialog box underMesh display on, enable Show and select

Geometry/Boundary selection.
3. In the History tree, right-clickModel and select Select All.
4. On theModel ribbon, select Front from theOrient drop-down list.

Display the Refined Mesh
1. In theMesh Visualization dialog box underMesh display on, enable Show and select

Geometry/Boundary selection.
2. In the History tree, right-clickModel and select Select All.
3. ExpandModel > delta_FFB0812_24EHE > delta_FFB0812_24EHE1 > Solids > AL-

Extruded.
4. Use the Ctrl key to deselect delta_FFB0812_24EHE_Case.

5. Click Close.
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6 - Create Monitor Points
Before running the simulation, create thermal and flow monitors for device_1_1 and cabinet_
default_side_maxy.

Create a Thermal Monitor
1. In the History tree, expandModel > Sheets > Source.
2. Right-click device_1_1 and select Assign Monitor > Point.
3. In theMonitor Setup dialog box, enter Device_temperature for the Name.
4. Expand Thermal and select Temperature.
5. ClickOK.

Create a Flow Monitor
1. In the Project Manager under Thermal, right-click cabinet_default_side_maxy and

select Select Assignment.
2. From the Icepakmenu, selectMonitor > Assign > Point.
3. In theMonitor Setup dialog box, enter Cabinet_opening_speed for the Name.
4. Expand Flow and select Speed.
5. ClickOK.
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7 - Define the Simulation Settings and
Run the Analysis

Define the Design Settings
1. From the Icepakmenu, select Design Settings.
2. On the Icepak Design Settings dialog boxGravity tab, selectGlobal::Y and Negative to

define the force of gravity in the negative Y direction based on the Global coordinate sys-
tem.

3. ClickOK.

Add a Solution Setup
1. In the Project Manager, right-click Analysis and select Add Solution Setup.
2. On the Icepak Solve Setup dialog boxGeneral tab, change theMaximum Number of

Iterations to 300.
3. Under Problem Types, retain the selections to solve for both Temperature and Flow.
4. Under Flow Regime, select Turbulent and clickOptions. In the Turbulent Flow Model

dialog box, retain the Zero Equation selection and clickOK.
5. Under Radiation Model, retain theOff selection to ignore heat transfer due to radiation.
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6. ClickOK
7. From the Filemenu, click Save.

Run the Simulation
1. In the Project Manager, expand Analysis.
2. Right-click Setup1 and select Analyze.

Note:When the simulation is complete, a message is displayed in theMes-
sages window stating "Normal completion of simulation on server."
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3. Right-click Setup1 and select Residuals to monitor the simulation residuals.

4. Click the Thermal Monitor tab to review the temperature monitor on the device.
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5. Click the Flow Monitor tab to review the speed monitor on the cabinet opening.
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6. Click Close

Add a Solution Setup and Run the Simulation 7-5

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 7-6

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with Icepak®: RF Amplifier



8 - Post-process the Results
The Ansys Electronics Desktop provides a number of ways to view and examine the solution res-
ults, including:

l Object face views
l Plane cut views
l Fields summary report

Create Object Field Overlays
Plot Temperature on the Heat Sink
1. In the History tree, expand Heatsink1.
2. Right-click Heatsink1_1 and select Select All.
3. Right-click in the 3D Modeler window and select Plot Fields > Temperature > Tem-

perature.
4. In the Create Field Plot dialog box, enable Specify Name and enter Heatsink.
5. Retain the Temperature selection forQuantity.
6. Enable Plot on surface only.
7. ClickOK.

Note: The field overlay appears in the Project Manager under Field Overlays
> Temperature. You can hide the overlay by right-clicking on it and selecting
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Plot visibility.

Plot Temperature on the Devices
1. In the History tree, expandModel > Sheets.
2. Right-click Source and select Select All.
3. Right-click in the 3D Modeler window and select Plot Fields > Temperature > Tem-

perature.
4. In the Create Field Plot dialog box, enable Specify Name and enter Devices_tem-

perature.
5. Retain the Temperature selection forQuantity and click Done.

Post-process the Results 8-2

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: RF Amplifier

Create Plane Cut Field Overlays
Create a Plane
1. From the Drawmenu, select Plane.
2. In the 3D Modeler window, click twice to draw a plane.
3. In the History tree, expand Planes and select Plane1.
4. In the Properties window, edit the following properties:

l Name: cut-plane
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l Root point: 0.068 ,0.31 ,0.136 meter
l Normal: 1 ,0 ,0 meter

Plot Speed
1. In the History tree, select cut-plane.
2. Right-click in the 3D Modeler window and select Plot Fields > Velocity > Speed.
3. In the Create Field Plot dialog box, enable Specify Name and enter cut-speed.
4. Retain the Speed selection forQuantity and clickOK.

5. In the Project Manager, expand Field Overlays > Speed.
6. Right-click cut-velocity and selectModify Plot.
7. In theModify Plot dialog box, select Velocity Vectors for theQuantity and click
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Done.overlay_cut-velocity

Create a Fields Summary Report
Create a fields summary report of object-specific solution data. Fields summary reports can
provide physical information from the solution about specific model boundary conditions or
objects.

1. From the Icepakmenu, select Fields > Create Fields Summary.
2. In the Setup Calculation dialog box, selectObject for Entity Type.
3. In the Entity list, select all of the Heatsink objects.
4. In theQuantity list, select HeatFlowRate.
5. From the Add drop-down list, select Add As Single Calculation.
6. Repeat steps 3 through 5 for the following entities and quantities.
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Note: You can select multiple entities at once. When an entity is selected, select it
again to clear the selection.

Entity Quantity
delta_FFB0812_24EHE_Case, delta_
FFB0812_24EHE_Passage, delta_
FFB0812_24EHE_Surface

VolumeFlowRate

All Heatsink objects Temperature

Note:When creating the entry for temperature on all heatsink objects, enable Include
all surface meshes before adding the calculation.
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9 - Summary
In this tutorial, you have learned about the basic usage of model using openings, fans, sources,
blocks, heat sinks, and walls to create an RF amplifier. You have also learned how to use the
Ansys Electronics Desktop Component Libraries to add a fan to a design. Furthermore, this
tutorial has introduced you to evaluating mesh quality as well as non-conformal meshing to
reduce cell count and computational cost.

Getting Started with Icepak®: RF Amplifier

Summary 9-1

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.


	Table of Contents
	1 - Introduction
	Set 3D UI Options

	2 - Create a Project and Build the Model
	Set Beta Option
	Create a Project
	Build the Model
	Resize the Cabinet

	View the Design List

	3 - Generate and Display Coarse Mesh
	Generate a Coarse Mesh
	Display the Coarse Mesh

	4 - Assign Mesh Regions
	Create the RF Amplifier Mesh Region
	Create a Non-Model Box
	Assign a Mesh Region to the Non-Model Box
	Assign a Mesh Region to the Fan Component

	5 - Generate and Display Refined Mesh
	Generate and Display Refined Mesh
	Display the Refined Mesh

	6 - Create Monitor Points
	Create a Thermal Monitor
	Create a Flow Monitor

	7 - Define the Simulation Settings and Run the Analysis
	Define the Design Settings
	Add a Solution Setup
	Run the Simulation

	8 - Post-process the Results
	Create Object Field Overlays
	Plot Temperature on the Heat Sink
	Plot Temperature on the Devices
	Create Plane Cut Field Overlays
	Create a Plane
	Plot Speed
	Create a Fields Summary Report

	9 - Summary

